没有预建的 wasm-opt 二进制文件

我正在尝试在我的树莓派 (3b) 上构建一些 webassembly rust 应用程序。一切都很顺利,虽然我在运行 wasm-pack 时遇到错误

~/rust/wasm-game-of-life $ wasm-pack build
[INFO]: Checking for the Wasm target...
[INFO]: Compiling to Wasm...
    Finished release [optimized] target(s) in 0.50s
[INFO]: Installing wasm-bindgen...
Error: no prebuilt wasm-opt binaries are available for this platform: Unrecognized target!
To disable `wasm-opt`, add `wasm-opt = false` to your package metadata in your `Cargo.toml`.

似乎没有为我的 (armv71) 平台找到 wasm-opt 二进制文件。但是从 here 克隆它们并自己构建它们似乎很容易。

但我的问题是如何将它们添加到 webassembly,以便找到它们?

编辑:要清楚,构建“成功”完成,即我可以运行包。但是,我想使用 wasm-opt 的大小或速度优化

stack overflow no prebuilt wasm-opt binaries
原文答案

答案:

作者头像

我相信目前还没有解决方案,因为它根本没有在代码中实现(但它似乎在 TODO 列表中:有 comments in the code ,但没有实际匹配的实现)。

我打开了一个 issue on the github ,它仍然是打开的。如果你有同样的问题,请在那个问题中报告,这样它会得到更高的优先级。

this issue report (特别是 this commit )建议了一个修复,但它还需要审查、测试和合并

更新 PR 已经合并,所以现在应该修复了。我不知道,因为我现在没有时间学习 Rust 🙂

相关问题