警告:您当前正在运行 @typescript-eslint/typescript-estree 未正式支持的 TypeScript 版本

您好,我的终端出现了一些错误,它说我需要使用 4.4.0 版本,而我当前的版本是...

在我的项目中,我当前的打字稿版本如下,

    "typescript": "^4.4.2",
    "typedoc": "^0.21.8",
    "react-scripts": "^3.4.4",
    "@typescript-eslint/eslint-plugin": "^4.29.3",
    "@typescript-eslint/parser": "^4.29.3",

此外,当我尝试运行 npm run dev 命令或 npx eslint . 时出现错误,如下所示,

    =============

   WARNING: You are currently running a version of TypeScript which is not 
   officially supported by @typescript-eslint/typescript-estree.

    You may find that it works just fine, or you may not.

   SUPPORTED TYPESCRIPT VERSIONS: >=3.3.1 <4.4.0

   YOUR TYPESCRIPT VERSION: 4.4.2

     Please only submit bug reports when using the officially supported 
    version.

    =============

我该如何解决这个问题,我在谷歌做了很多研究,但没有任何效果。这对我会有很大的帮助。

stack overflow WARNING: You are currently running a version of TypeScript which is not officially supported by @typescript-eslint/typescript-estree
原文答案

答案:

作者头像

尝试使用 >=3.3.1 <4.4.0 之间的typescript版本。 Here 你有可用的typescript版本列表。

更改版本后,删除 node_modules 文件夹和 package-lock.json 文件。然后执行 npm install

作者头像

我不会降级我的 Typescript,因为你会错过更新的 TS 功能——我会找到更新 @typescript-eslint/typescript-estree 的方法。

您可能没有直接安装它,这可能是另一个包的依赖项,例如 @typescript-eslint/experimental-utils@typescript-eslint/eslint-plugin 的依赖项,因此请在 yarn.lock / package.lock 文件中跟踪父包并将其碰撞,如结果它也应该碰到 @typescript-eslint/typescript-estree

相关问题