webpack 服务给出“无效的正则表达式”错误

我正在尝试运行 webpack serve

它给了 SyntaxError: Invalid regular expression: /(p{Uppercase_Letter}+|p{Lowercase_Letter}|d)(p{Uppercase_Letter}+)/: Invalid escape

在这一行 https://github.com/webpack/webpack/blob/c90dfadbc6c5ac1ab4bda2cc106958b65fb5e6e7/lib/cli.js#L67

"webpack": "5.1.3",
"webpack-cli": "4.0.0",
"webpack-dev-server": "3.11.0"

Node 12.19.0

我错过了什么吗?

stack overflow webpack serve giving "Invalid regular expression" error
原文答案
author avatar

接受的答案

我今天也有同样的问题。我通过将我的节点版本更新到最新的稳定版本来解决它

sudo npm cache clean -f
sudo npm install -g n
sudo n stable

答案:

作者头像

我运行的是 Node 8.9.1 而不是最新的稳定版本,这导致了问题。

nvm install stable
nvm use stable
作者头像

在我的情况下(节点 12,Webpack 5.3.1),将 webpack-cli 更新到 4.2.0 解决了这个错误

作者头像

我无法升级到最新的 node 因为它会迫使我升级我的 Angular 站点。我使用此命令修复错误:

npm install webpack@4.42.0 webpack-cli@3.3.11 webpack-dev-server@3.10.3 --save-dev

基本上它会强制使用没有错误的 webpack 版本。

作者头像

在 Ubuntu 上,我首先删除了 node.js 并使用 snap 重新安装,这为我解决了这个问题

sudo apt-get remove nodejs
sudo snap remove node
sudo snap install node --classic
作者头像

我面临着同样的问题,我将节点版本从8.x切换到16.x,并使用此命令进行修复:

[dolphin@MiWiFi-R4CM-srv]~/Documents/GitHub/crx-selection-translate% nvm list
->      v8.17.0
       v10.24.1
       v16.13.0
        v17.2.0
         system
default -> 8 (-> v8.17.0)
iojs -> N/A (default)
unstable -> N/A (default)
node -> stable (-> v17.2.0) (default)
stable -> 17.2 (-> v17.2.0) (default)
lts/* -> lts/gallium (-> N/A)
lts/argon -> v4.9.1 (-> N/A)
lts/boron -> v6.17.1 (-> N/A)
lts/carbon -> v8.17.0
lts/dubnium -> v10.24.1
lts/erbium -> v12.22.7 (-> N/A)
lts/fermium -> v14.18.2 (-> N/A)
lts/gallium -> v16.13.1 (-> N/A)
[dolphin@MiWiFi-R4CM-srv]~/Documents/GitHub/crx-selection-translate% nvm use 16
Now using node v16.13.0 (npm v8.1.0)

希望它能帮助他人。WebPack版本 "webpack": "^5.67.0"