带有引导程序 5 的 datetimepicker 无法正常工作

我对 JS 很陌生,并试图将 datetimepicker 添加到我的网络演示中。本教程适用于 bootstrap 3.3.7,但是当我将其更改为版本 5 时,日历不再显示。

最小的工作html如下

<!-- this works OK -->
<!-- <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css"> -->
<!-- this does not! -->
<link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/bootstrap@5.1.3/dist/css/bootstrap.min.css">
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/bootstrap-datetimepicker/3.1.3/css/bootstrap-datetimepicker.min.css">

<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/moment.js/2.9.0/moment-with-locales.min.js"></script>
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.2/js/bootstrap.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/bootstrap-datetimepicker/4.7.14/js/bootstrap-datetimepicker.min.js"></script>

<div class='input-group date' id='datetimepicker1'>
  <input type='text' class="form-control"/>
  <span class="input-group-addon">  
    <span class="glyphicon glyphicon-calendar"></span>
  </span>
</div>

<script>
  $(".date").datetimepicker({locale: "ru"});
</script>

我在项目中使用 bootstrap@5.1.3 并且不想因为一个日期时间选择器而改变它。我已经尝试了许多变体,但没有一个有效。我怎样才能让它工作?

正如 https://stackoverflow.com/a/68683409/8900030 所述, https://cdnjs.cloudflare.com/ajax/libs/bootstrap-datetimepicker/4.17.47/js/bootstrap-datetimepicker.min.js 适用于 Bootstrap 3,而不是 Bootstrap 5。

我应该改用哪个版本? (我怎么知道?)

另请注意,我需要 {locale: "ru"} 参数,该参数在 bootsrap 3 AFAIK 中不可用。

stack overflow datetimepicker with bootstrap 5 not working properly
原文答案
author avatar

接受的答案

继任者在这里: https://getdatepicker.com/

它不再需要自举,jQuery或时刻。在此处查看安装文档 https://getdatepicker.com/6/installing.html


答案: