为什么我不能在新的 ubuntu:22.04 中运行 `apt update` ?

我目前无法在新的 apt update (代号 ubuntu:22.04 )中运行 jammy

协议

$ docker --version
Docker version 20.10.2, build 2291f61

$ docker run --init --rm -it ubuntu:22.04
root@123456789:/# apt update

### 观察到的

$ docker run --init --rm -it ubuntu:22.04
root@6444bf2cb8b4:/# apt update
Get:1 http://archive.ubuntu.com/ubuntu jammy InRelease [270 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [90.7 kB]            
Get:3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [90.7 kB] 
Get:4 http://security.ubuntu.com/ubuntu jammy-security InRelease [90.7 kB]             
Get:5 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 Packages [164 kB]
Get:6 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages [1792 kB]       
Get:7 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 Packages [266 kB]           
Get:8 http://archive.ubuntu.com/ubuntu jammy/universe amd64 Packages [17.5 MB]             
Fetched 20.2 MB in 1s (17.6 MB/s)                                                           
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'
E: Sub-process returned an error code
root@6444bf2cb8b4:/# 

预期的

apt update 像在 ubuntu:20.04 基础图像上一样传递...

注意:与 apt-get install 相同的问题 ...

参考: https://hub.docker.com/_/ubuntu

stack overflow Why I cannot run `apt update` inside a fresh ubuntu:22.04?
原文答案
author avatar

接受的答案

似乎这与 clone3 对系统调用 Glibc >= 2.34 的使用有关...

所以你需要 Docker >= 20.10.9 来修复它。

参考: https://github.com/moby/moby/pull/42681
参考: https://pascalroeleven.nl/2021/09/09/ubuntu-21-10-and-fedora-35-in-docker/


答案:

作者头像

我遇到了同样的问题。这是我的战术解决方法。

对于上下文...

我正在一个 Gitpod 实例中工作。

$ docker --version
Docker version 20.10.12, build e91ed57
$ docker pull ubuntu:22.04
$ docker run --rm -it ubuntu:22.04 /bin/bash

root@2fcf92fb7c84:/# apt update
Get:1 http://security.ubuntu.com/ubuntu jammy-security InRelease [90.7 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy InRelease [270 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [90.7 kB]
Get:4 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [90.7 kB]
Get:5 http://archive.ubuntu.com/ubuntu jammy/universe amd64 Packages [17.5 MB]
Get:6 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 Packages [266 kB]
Get:7 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 Packages [164 kB]
Get:8 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages [1792 kB]
Fetched 20.2 MB in 2s (11.1 MB/s)
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'
E: Sub-process returned an error code

快速纳米安装...

尽管出现上述错误消息,但更新足以安装 nano 。我忽略了 nano 安装结束时的误导性错误消息。

root@3958950e9c57:/# apt install nano
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
  :
E: Problem executing scripts DPkg::Post-Invoke 'rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true'
E: Sub-process returned an error code

我的修复...

我使用 nano 编辑 /etc/apt/apt.conf.d/docker-clean ,注释掉第二行 ( APT::... )。我随后在第 1 行 ( DPkg::... ) 遇到了类似的错误消息;所以,它也被注释掉了。

一起删除 docker-clean 可能没问题;但是现在,我已经留下了一条线。

Both '//' and '#' can be used to comment out lines.

root@3958950e9c57:/# nano /etc/apt/apt.conf.d/docker-clean

  .. nano session not shown ..

root@3958950e9c57:/# cat /etc/apt/apt.conf.d/docker-clean
# DPkg::Post-Invoke { "rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true"; };
# APT::Update::Post-Invoke { "rm -f /var/cache/apt/archives/*.deb /var/cache/apt/archives/partial/*.deb /var/cache/apt/*.bin || true"; };
Dir::Cache::pkgcache ""; Dir::Cache::srcpkgcache "";

结果 ...

由现在注释掉的行产生的令人困惑的消息消失了。

root@beab61fbde20:/# apt update
Hit:1 http://archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://security.ubuntu.com/ubuntu jammy-security InRelease
Hit:3 http://archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu jammy-backports InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done

需要改进...

更好的解决方案是修复我已注释掉的行。我无法找到正确的编辑;所以,只是把这行注释掉了。

在docker...

我用 sed 代替 nano

FROM ubuntu:22.04
USER root

RUN sed -i -e 's/^APT/# APT/' -e 's/^DPkg/# DPkg/' 
      /etc/apt/apt.conf.d/docker-clean

然后,标记调整后的 Ubuntu 映像以供本地使用。

docker build -t fixed-ubuntu:22.04 -f Dockerfile .
作者头像

我将 docker 引擎升级到版本 20.10.14 并解决了问题。

作者头像

我有 docker 20.10.18(最新的写作时间)没有工作,20.10.14 它开始工作。

相关问题